Firefox4正式版で玉砕

★画像アップ先の不調により、過去のエントリーで画像が見られないものが多数あります。もし画像の見たいものがありましたらご連絡いただければ復活するようにします。

*普通に使う分には問題ないと思いますので、ご心配なく。

以前のエントリーでFirefox4βをインストールして使ってたのですが、
正式版が出たので、早速導入してみましたが、
Firefox4βでは問題なかったのに、正式版で玉砕しました。
まずFirefox4正式版のインストール(10.04、10.10)は

$ sudo add-apt-repository ppa:mozillateam/firefox-stable
$ sudo apt-get update && sudo apt-get upgrade

*Firefox3.6は上書きされます。

参考:Firefox 4 PPA for Ubuntu 10.04 and 10.10 users/OMG UBUNTU!

Firefoxメニューの日本語化

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/4.0/win32/xpi/

ここから「ja.xpi」をクリックしてインストールで、日本語化できます。

参考:Firefox 4 Ubuntu 10.04にPPAからアップグレード インストールして日本語化する/ubuntuApps

これで普通にFirefox4正式版が使えるようなります。(わたしもここまでは問題ありません)

本題はここから、

Firefox4はまだアドオンが対応していないものがあって
わたし的には正式に移行するのをためらっていたのですが、

Firefox4で動作しないアドオンを動作させる方法/Gigazine

という記事があって、試しにFirefox4βで適用してみたところ、
ほとんど問題なく対応できました。

実際の適用の仕方は、上記のページの下の方にある、
Nightly Tester Tools」のアドオンをインストールします。



インストールしたら、Firefoxを再起動して、
「ツール」>「Nightly Tester Tools」>「Force Addon Compatibility」
をクリック、もう一度Firefoxを再起動すればOKです。

Nightly Tester Tools適用

これで、現時点で対応していないアドオンも使えるようになります。

*多少の不具合がある可能性はあります。

Firefox4βでMouseoverDictionary、Zoho Notebook Helperあたりが
使えるようになったので、Firefox4正式版に移行しても問題ないと思って、
インストール&「Force Addon Compatibility」を適用して、
Firefoxの再起動をかけたところ…

ここで問題が発生!

「Firefox起動時にエラー XML パースエラー: 定義されていない実体が使用されています。」

というエラー(スクリーンショット撮っておけばよかった)が出て、
Firefoxが起動できません! Firefox4βでは問題なかったのに?です。
Firefox4βと同じアドオンが入っているはずなのですが?
というわけでここで玉砕です。
仕方ないので、アドオンが正式に対応するのを待つことにして、
Firefox3.6にダウングレードしました。
たぶんわたしの環境固有のものだと思いますが?

それと、もし同様の現象が出た場合の復帰の仕方は、
ホームフォルダにある隠しファイルを表示して、
「.mozilla」>「firefox」をバックアップ取って、
一度削除して、Firefoxを立ち上げれば復帰します。
そのあと、バックアップ取った「firefox」内のアドオン関係などを
差し替えれば設定なども復帰できます。
その中のどれかのファイルが(どれか知りませんが)、
「Nightly Tester Tools」関連のファイルなので、
それを避けるように、あたりをつけて少しずつ確認するといいでしょう。

【追記】
Firefox4をセーフモードで起動してエラー回避できる可能性があるそうです。

$ firefox -safe-mode

端末からセーフモードでアドオン無効にチェックを入れてから起動
アドオンの言語パックの中にバージョン3.6と4.0が混在する場合は3.6を無効にすると
エラーを回避できるかもしれません。

おせっかいマンさんよりコメントいただきました。
ありがとうございます。


関連記事

テーマ : Linux
ジャンル : コンピュータ

コメントの投稿

非公開コメント

エラーの件

Firefox4を端末からセーフモードでアドオン無効にチェックを入れてから起動して( $ firefox -safe-mode ) アドオンの言語パックの中にバージョン3.6と4.0が混在する場合は3.6を無効にするとエラーを回避出来る可能性が有りますですぅ~

RE:エラーの件

おせっかいマンさん、こんにちは。

セーフモードで起動という技があったのですね。
知りませんでした。
情報ありがとうございます。
追記させていただきます。
プロフィール

TOY

Author:TOY
萌え萌えmoebuntu
ようこそ!
moebuntuサイト
moebuntu wiki
お気軽にコメントください。

Auto-Translate
最新記事
最新コメント
tweet
萌え萌えAD




月別アーカイブ
07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01 
カテゴリークラウド
RSSリンクの表示
リンク
QRコード
QRコード
最新トラックバック