FC2ブログ

Wine 5.0(安定版)をUbuntu 18.04に依存関係問題を回避しつつインストールする方法

★画像アップ先の不調により、過去のエントリーで画像が見られないものが多数あります。もし画像の見たいものがありましたらご連絡いただければ復活するようにします。

Ubuntu 18.04環境では「winehq-stable」の依存関係で、インストールするにはひと手間必要のようでした。私の環境でも少し前(Wine 5.0リリース後?)からシステムのアップデート時に「winehq-stable」のアップデートが依存関係の問題で保留となっていました。そんなこんなでしばらく放置していたのですが、以下のサイトの手順で無事インストールできたので、その様子をご紹介します。

How to Install Wine 5.0 Stable in Ubuntu 18.04, 19.10
Wine 5.0(安定版)


\もしよかったらお願いします。/
●受取人の欄にmoebuntu★gmail.com(「★」は「@」に置き換える)で寄付(15円〜)できます。
Amazonギフト券(Eメールタイプ)
Amazonギフト券(Eメールタイプ)

インストール

Ubuntu 18.04環境の場合下準備として、まず上記サイトの黄色の地色の部分をする必要があるようです。端末(Ctrl+Alt+T)を開いて以下を入力適用します。(Terminal~$)

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

次に引き続き以下を1行ずつ入力適用すればインストール完了です(リポジトリはUbuntu 18.04用です)。

*他の環境の場合リポジトリとか違うので、上記サイトをご参照ください。

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key; sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport
sudo apt update && sudo apt install --install-recommends winehq-stable

以下に上記一連の流れのスクショを載せておきます。

*最初の下準備部分は訳あって再度インストール操作した時の画面なのですべて‘すでに最新バージョンです’となっています。

Wine 5.0(安定版) Wine 5.0(安定版) Wine 5.0(安定版) Wine 5.0(安定版) Wine 5.0(安定版)

これで無事インストールできました。

設定画面でバージョンの確認

Wineの設定画面は以下のコマンドで出ます。
上記同様端末(Ctrl+Alt+T)を開いて以下を入力適用すればOKです。(Terminal~$)

winecfg

Wine 5.0(安定版)

文字化け対策が必要な場合

今回未検証ですが、Wine 3.0(安定版)がリリース、そのインストール方法に書いてある方法で大丈夫だと思います。

関連記事

テーマ : Linux
ジャンル : コンピュータ

コメントの投稿

非公開コメント

staging版でしのいでたので、stableに直しました。

 お久しぶりです。
 Wine4.0を使っていて、インストール保留がなくならなかったため、
https://qiita.com/nanbuwks/items/a18dd35ad83ab70879b4
でしのいでいましたが、後から気づいたんですが、staging5.1だったんですね^^;
 そのまま、remove,installできました。
(staging版のPPA等で問題なかったようです)
 ここ見てから、気づいてwinecfgしてよかったです。

Re: staging版でしのいでたので、stableに直しました。

Mifjpn さん、いつもコメントありがとうございます。

お役に立てて何よりです。

ところで、もうそろそろUbuntu 20.04 LTSの足音が聴こえて来つつありますが、
途中すっ飛ばした分仕事量が増えてちょっと憂鬱(心配)です。
以前アルファから手を付けたらあまり意味がなかったので、ベータからやるつもりですが…
そうするとリリースまでの日数が少ないというディスアドバンテージがあるんですよね。

お疲れ様です

お疲れ様です。
 βからということで了解しました。
 2020年4月2日~2020年4月23日ですね。
ずいぶんタイトです^^;
 とはいえデイリービルドではいつ差し替えられるか分かったもんじゃないですもんねぇ。
 今年は人事異動も大きくありそうなので、なかなか難しいかもしれませんが、できるだけやってみましょう^^。
 ダークテーマが落ち着いてくれて定義の仕方が変わってないことを祈るばかりです。

Re: お疲れ様です

Mifjpn さん、またお世話になります。

> ずいぶんタイトです^^;

どう考えてもリリースには間に合わないと思うので、
とりあえずは既存のUbuntu 18.04用のものが暫定的に使えるかどうかのチェックをし、
大丈夫であればやや落ち着きつつできるだけ間が開かないうちに完成させる。
ダメであればなる早で頑張るって感じですね。
まあ頑張っても3ヶ月位は掛かりそうな気がします。
というわけで、ボタン周りも急ぐことはありませんので、よろしくお願いします。

wine 5.0がインストールできません(T_T)

いつもこちらでubuntuの勉強をさせていただいてます。ありがとうございます。

Windows10のVMware上でUbuntu18.04を使ってますが、遅ればせながらwineをインストールしようと思い、こちらの記事の最初のコマンドを打ち込んだところ、以下の表示がされてしまいました。
もし対応策がわかればご教授いただければ幸いです。

なおVMwareで別環境を用意し確認しましたが、Ubuntuソフトウェアから3.0はイントールできました。

---表示内容---

インストールすることができないパッケージがありました。おそらく、あり得ない状況を要求したか、(不安定版ディストリビューションを使用しているのであれば) 必要なパッケージがまだ作成されていなかったり Incoming から移動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
libasound2-plugins:i386 : 依存: libpulse0:i386 (>= 0.99.1) しかし、インストールされようとしていません
libsdl2-2.0-0:i386 : 依存: libpulse0:i386 (>= 0.99.1) しかし、インストールされようとしていません
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

---以上----

Re: wine 5.0がインストールできません(T_T)

ハム太郎 さん、こんにちは。


出だしてつまずきましたか!
残念ながらわたしにはわかりませんね。
本日別の内容で似たようなことに関するものをアップ(未解決)したので、
もしかしたら参考になるかもしれません。

Wine 3.0がインストールできたとのことなので、まずはWine 4.0を試してみてはどうでしょう?
↓これのPPAでWine 4.0になったような気がします。

Wine 3.0(安定版)がリリース、そのインストール方法
http://moebuntu.blog48.fc2.com/blog-entry-1138.html

違っていたらゴメンナサイ。
その場合ググれば4.0用のPPAが見つかると思います。

あと、壊れたパッケージ(があるなら)はSynnapticパッケージマネージャで
とりあえず修復はできると思います。

諦めて新規インストールしました

管理人様

返信ありがとうございました。

Wine 3.0はインストールできてもWindowsアプリがエラーが出てインストール不可。
Synnapticパッケージマネージャで確認しても壊れてるパッケージは無し。
その他、ネットでいろいろ調べて色々なインストールを試みましたが改善されず・・・
結局、表題の通り新規インストールしたらあっさりインストールできて快調に使用できています。
でも使いたかったWindowsアプリがほとんどインストールに失敗したので20.04でWineを使うかどうか思案してます。

これからも時々こちらのサイトを拝見させていただきます。
大変だと思いますが、素晴らしい情報をこれからも宜しくお願いいたします。

Re: 諦めて新規インストールしました

ハム太郎さん、こんにちは。


ちょっと出かけていて返信が遅れました。
新規インストールでうまく行ってよかったですね。

>でも使いたかったWindowsアプリがほとんどインストールに失敗したので20.04でWineを使うかどうか思案してます。

<使いたいアプリ> Ubuntu Wine とかで検索するともしかしたら方法(もしくはダメな理由)が見つかるかもしれません。

また、そこそこメジャー系であれば↓こちらを参考にデータベースで調べていみると状況が分かるかもしれません。

LinuxでWindowsソフトが使えるWine…あのアプリはどう?
https://report.hot-cafe.net/wine-appdb-5916#Wine_Application_Database_AppDB

>これからも時々こちらのサイトを拝見させていただきます。

今後ともよろしくお願いします。
プロフィール

TOY

Author:TOY
萌え萌えmoebuntu
ようこそ!
moebuntuサイト
moebuntu wiki
お気軽にコメントください。

Auto-Translate
最新記事
最新コメント
tweet
萌え萌えAD




月別アーカイブ
07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01  12  11  10  09  08  07  06  05  04  03  02  01 
カテゴリークラウド
RSSリンクの表示
リンク
QRコード
QRコード
最新トラックバック